A problem was identified (and fixed) in the calculation of the new update subscription expiry date if you renewed early. All early renewals will be checked and corrected aaccordingly. You will be notified if your license needs to be updated via email.

Black Friday , SPAD.neXt 0.9.7 and a new FIP?

Locked
User avatar
c0nnex
Site Admin
Posts: 4995
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

Black Friday , SPAD.neXt 0.9.7 and a new FIP?

Post by c0nnex » 29 Nov 2019, 01:36

Black Friday is here!

For the first time we are offering 25% discount on everything for the period of Nov. 29th through Dec. 6th
This applies to new licenses, as well as upgrades or update renewals.

The discount will be applied automatically upon checkout.

SPAD.neXt 0.9.7 at the doorsteps

SPAD.neXt 0.9.7 is about to be released in early December, bringing some new features:
* Support for all Go2Flight devices and the Polulu servo controller (e.g. for analog gauges)
* Support for custom arduino/atmega/teensy based devices (see https://github.com/c0nnex/SPAD.neXt/wik ... Connection for details)
* Support for the PMDG 737 NGXu
* Support for a new (not yet available) Flight Sim. To be revealed as soon as it is available for purchase
* Support for Dovetail Train Simulator
and many other little QoL improvements.
To get your hands on the 0.9.7 public beta now, just enable the beta updates in SPAD.neXt (Application Settings)
The current changelog is available in the forums.

A new FIP for you?

In the past years, we have been asked over and over again, if there is an alternative for the Saitek/Logitec Flight Instrument Panel.
Currently there is not, and the drawbacks of the Saitek FIP start to bring up real problems like
* Not many computer come with USB2.0 ports anymore. Saitek FIP only support USB2.0
* The firmware for the FIP is over 10 years old and crashes frequently

We are currently looking into options to craft such a device and would like to ask you to participate in this poll , so we can plan according to your needs.=

Locked