Due to relocation there will be slow response to tickets until i have a decent internet line again.

Honeycomb Aeronautical Flight Yoke and Switch Panel

General Discussions
Post Reply
Gerry_B
Passenger
Posts: 2
Joined: 07 Oct 2017, 23:49
Status: Offline

Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by Gerry_B » 01 Nov 2019, 15:12

will the new Honeycomb Aeronautical Flight Yoke and Switch Panel work with SPAD.neXt?

User avatar
c0nnex
Site Admin
Posts: 4966
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by c0nnex » 01 Nov 2019, 15:36

SInce the yoke is just a "Joystick" it should be supported out of the box.
No idea about the switches and stuff. WIll need a tester for that as i do not own that device

chrishoppy
Flight Attendant
Posts: 19
Joined: 18 Jun 2019, 21:19
Location: England UK
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by chrishoppy » 03 Nov 2019, 14:26

honeycomb works with spad all buttons show up and are configurable.

Hazza
Betatester
Posts: 97
Joined: 10 Mar 2015, 22:00
Location: Christchurch, NZ
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by Hazza » 05 Nov 2019, 08:55

I can also confirm that it works OOB (Out Of the Box)

szcsongor
Passenger
Posts: 5
Joined: 07 Sep 2017, 22:53
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by szcsongor » 08 Nov 2019, 18:49

Yesterday I configured all the buttons and axes of my honeycomb. Today as I start spad.next for a flight just to see it greeting me with the message "This device is currently not configured. Do you want to use a default configuration?". WTF?
I spent about an hour to set it up, now it's gone. It's plugged in the same usb port and basically nothing has changed besides turning off and on the computer. If I remember well, this happened before with other devices, spad.next just suddenly forgets them and recognize them as new devices. Very annoying!
Luckily I saved and backed up the xml config file that actually has all the assignments, only spad does not see them anymore and asks me to set it up again. What is the solution in this case?

szcsongor
Passenger
Posts: 5
Joined: 07 Sep 2017, 22:53
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by szcsongor » 08 Nov 2019, 19:38

update:
I circumvented the problem by starting a new profile and setting up just one button for the honeycomb yoke to put it in the profile. Then I copied all the rest from the old xml to this new one and saved. Now the new profile works, all the assignments are there.
Now I wonder when spad.next will decide again that it never saw this device before and wants to set it up. Will back up all my profiles from now on.

lesoreilly
Captain
Posts: 195
Joined: 31 Jul 2015, 01:07
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by lesoreilly » 09 Nov 2019, 18:13

I also "publish" a lot of my Devices...So not just the entire profile but the devices...That way I can "import" a device into new profiles :)

User avatar
c0nnex
Site Admin
Posts: 4966
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by c0nnex » 10 Nov 2019, 17:41

Sometimes Windows chnage sthe USB Identifiers for Devices (often after updates). For devices that do not provide a serial number, the USB Identifier is the only way for SPAD.neXt to re-recognize a device. If it changes, SPAD.neXt will try to find it again, but if it fails it cannot load the stuff.
If it happens again, please open a ticket, and attach the old saved profile as well.

szcsongor
Passenger
Posts: 5
Joined: 07 Sep 2017, 22:53
Status: Offline

Re: Honeycomb Aeronautical Flight Yoke and Switch Panel

Post by szcsongor » Yesterday, 00:36

lesoreilly wrote:
09 Nov 2019, 18:13
I also "publish" a lot of my Devices...So not just the entire profile but the devices...That way I can "import" a device into new profiles :)
Thanks for the tip, I will also do this from now on.
c0nnex wrote:
10 Nov 2019, 17:41
Sometimes Windows chnage sthe USB Identifiers for Devices (often after updates). For devices that do not provide a serial number, the USB Identifier is the only way for SPAD.neXt to re-recognize a device. If it changes, SPAD.neXt will try to find it again, but if it fails it cannot load the stuff.
If it happens again, please open a ticket, and attach the old saved profile as well.
Yes, I suspected that this could be the reason. I tried to check the long device identifier in the xml file, but it was all the same, spad still could not recognize the assignments.
But I was actually wrong, the device was plugged out from the usb and then plugged back in the same socket of a usb hub. No windows updates happened meanwhile.
Anyway, I will just backup the device profiles in case this happens again.

Post Reply