SPAD remains in WIN system

Discussion about Problems.
Forum rules
If you have technical Problem, please open a ticket: https://www.spadnext.com/discover/how-to/get-help.html

Do NOT hijack other people threads, until you have exactly the same problem!
Locked
User avatar
alihor
Donator
Posts: 41
Joined: 07 Jul 2015, 13:09
Location: Erlangen, Germany
Status: Offline

SPAD remains in WIN system

Post by alihor » 28 Jun 2019, 22:21

Hallo Ulrich,
since some weeks I have the following strange behaviour of SPAD functionality:
when I start my PC (WIN7) and start FSX or P3D, then the 3 Saitek moduls are activated. SPAD is NOT started yet. I looked for some remains of SPAD DLLs or other code, but I didn't find any.
When I start SPAD and exit again, then the activation is gone. But after next boot and start the PC the activation is there again.

What is the reason for this behaviour and how can I debug? What Saitek/SPAD drivers should not be there in the system?

herzliche Grüße
Alhard
best regards
....Alhard (EDDN)
PC pilot since 1980, WIN7, FS9+FSX+P3DV4, 3 PCs, 6 Monitors, IVAO

User avatar
c0nnex
Site Admin
Posts: 4933
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

Re: SPAD remains in WIN system

Post by c0nnex » 05 Jul 2019, 13:23

Check the DLL.XML of FSX/P3D for saitek stuff and such. Sounds like some other DLL is working with the panels

User avatar
alihor
Donator
Posts: 41
Joined: 07 Jul 2015, 13:09
Location: Erlangen, Germany
Status: Offline

Re: SPAD remains in WIN system

Post by alihor » 10 Jul 2019, 10:53

Hallo Ullrich, danke für den Tipp.
But there was no entry in DLL.XML which I already checked.
There was an entry in EXE.XML like this, which I disabled AGAIN
  • <Launch.Addon>
    <Name>Saitek DirectOutput RadioStack</Name>
    <Disabled>true</Disabled>
    <Path>C:\Program Files (x86)\Saitek\DirectOutput\SaiFlightSimX.exe</Path>
    <CommandLine>-run</CommandLine>
    </Launch.Addon>
    <Launch.Addon>
    <Name>Saitek Panel(s) Plugin for FSX</Name>
    <Disabled>true</Disabled>
    <Path>C:\Program Files (x86)\Saitek\Pro Flight Panels\SaiPanelsFS9.exe</Path>
    <CommandLine>-run</CommandLine>
    </Launch.Addon>
It probably came again in, while I reinstalled USB Hardware. Probably :o
Question: shall I finally delete this Saitek stuff from my system??

Thanks for your help.
best regards
....Alhard (EDDN)
PC pilot since 1980, WIN7, FS9+FSX+P3DV4, 3 PCs, 6 Monitors, IVAO

User avatar
c0nnex
Site Admin
Posts: 4933
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

Re: SPAD remains in WIN system

Post by c0nnex » 10 Jul 2019, 12:14

If you have no FIP, you can safely uninstall everything.
If you have a FIP, keep the FIP-Driver but disable the services.

Locked