SPAD.neXt 0.9.6.50 has been released to public

Setting Multipanel buttonlight based on LVAR doesn´t work

Discussion about Problems.
Forum rules
If you have technical Problem, please open a ticket: https://www.spadnext.com/discover/how-to/get-help.html

Do NOT hijack other people threads, until you have exactly the same problem!
Locked
Nyruami
Passenger
Posts: 4
Joined: 06 Feb 2019, 11:45
Status: Offline

Setting Multipanel buttonlight based on LVAR doesn´t work

Post by Nyruami » 02 Mar 2019, 11:17

Hi, I´m predominantly flying the Aerosoft A320 on P3D v4.4, so I made a profile that should resemble Airbus logic as close as possible. So I wanted the button lights on the Multipanel to be permanently on when the Airbus is in managed mode, and off when it is in selected mode, as there actually is no "off" mode, as long as Autopilot is on.

So I wanted the button light, in this example the light for the ALT selected button to get its state by looking up the LVAR that tells if the AIrbus is in managed mode or not.

I programmed an Altidude Hold (Change Buttonlight) event, in the coditional field I entered "IF AB_AP_ALT_MODE99(LVAR) equals 0" and in the action window I put "Switch Multi Panel ALT to shortmode on (permanent on)" and of course an event that changes the button light to off when the LVAR equals 1

Well, this simply does nothing, the button is in long mode (button blinking), which isn´t actually programmed at all under any conditions, from the start of the simulator and it stays in long mode no matter what I do. When I click on the variable in condition field Spad.next shows it in 0 when I put the Airbus in Altidude managed mode and 1 when I put selected mode, so SPAD.next reads the variable and its content correctly, it just doesn´t care that I want to have the light of the Multi Panel changed based on this variable.

What did I do wrong?

User avatar
c0nnex
Site Admin
Posts: 4855
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

Re: Setting Multipanel buttonlight based on LVAR doesn´t work

Post by c0nnex » 15 Mar 2019, 19:30

In the Device Settings set "Light equals Buttonmode" to OFF if you want to control the button lighing yourself. Else SPAD.neXt will handle the lights (and set it to blinking if the button is currently in long mode)

Locked