SPAD.neXt 0.9.6.50 has been released to public

Spad.next complete, mjc8Q400 & Saitek Radio Panel ADF

Discussion about Problems.
Forum rules
If you have technical Problem, please open a ticket: https://www.spadnext.com/discover/how-to/get-help.html

Do NOT hijack other people threads, until you have exactly the same problem!
Post Reply
seanpa
Passenger
Posts: 3
Joined: 26 Oct 2018, 11:51
Status: Offline

Spad.next complete, mjc8Q400 & Saitek Radio Panel ADF

Post by seanpa » 07 Jan 2019, 08:52

Hi,
I am having problems programming the ADF for mjc8Q400.

As far as I am able to tell the ARCDU panel relies on two variables:
ADF ACTIVE FREQUENCY:1 for the Active Setting
ARCDU1=> Left ARCDU ADF Stby Frequ.

If I use a knob turn to reduce ADF ACTIVE FREQUENCY:1 it changes on the Saitek but not on the ARCDU. To that end the standby must be used.

If i try to use a knob turn to reduce ARCDU1=> Left ARCDU ADF Stby Frequ. however a weird division by 10 seems to occur and and also a round up from 1 decimal place to an integer. This also appears to happen if I try to make ARCDU1=> Left ARCDU ADF Stby Frequ. = ARCDU1=> Left ARCDU ADF Stby Frequ.

If anyone else has seen this occur can you let me know especially if you have a solution.

Kind regards
Sean

User avatar
c0nnex
Site Admin
Posts: 4804
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

Re: Spad.next complete, mjc8Q400 & Saitek Radio Panel ADF

Post by c0nnex » 09 Jan 2019, 14:31

For the Q400 you will need to use the Q400 LVAR not the SimConnect Standards

seanpa
Passenger
Posts: 3
Joined: 26 Oct 2018, 11:51
Status: Offline

Re: Spad.next complete, mjc8Q400 & Saitek Radio Panel ADF

Post by seanpa » 10 Jan 2019, 09:16

Hi, C0nnex,

Based on your info, i have reprogrammed as follows:

<BaseEvent xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" BoundTo="RADIOPANEL_LOWER_SELECTOR_ADF" xmlns="http://www.fsgs.com/SPAD">
<EventDefinitions>
<EventDefinition Trigger="LEFTDISPLAY">
<EventActions>
<EventActionDisplayValue TargetDataDefinition="Q400:0001:8546" TargetDisplay="LEFTDISPLAY" DisplayFormat="000.0" DisplayConvert="Divide10" />
</EventActions>
</EventDefinition>
<EventDefinition Trigger="RIGHTDISPLAY">
<EventActions>
<EventActionDisplayValue TargetDataDefinition="Q400:0000:FB89" TargetDisplay="RIGHTDISPLAY" DisplayFormat="000.0" />
</EventActions>
</EventDefinition>
<EventDefinition Trigger="TUNER_OUTER_CLOCKWISE">
<EventActions>
<EventActionChangeValue TargetDataDefinition="Q400:0000:FB89" ValueOperation="Increment" Value="10" />
</EventActions>
</EventDefinition>
<EventDefinition Trigger="TUNER_OUTER_COUNTERCLOCKWISE">
<EventActions>
<EventActionChangeValue TargetDataDefinition="Q400:0000:FB89" ValueOperation="Decrement" Value="10" />
</EventActions>
</EventDefinition>
<EventDefinition Trigger="ACTIVATESHORT">
<EventActions>
<EventActionChangeValue TargetDataDefinition="Q400:0001:3E78" ValueOperation="Set" Value="3" />
</EventActions>
</EventDefinition>
</EventDefinitions>
<Options>
<Option Key="TUNER_INNER_SENSITIVITY" Value="100" />
<Option Key="TUNER_OUTER_SENSITIVITY" Value="100" />
</Options>
</BaseEvent>


However as I turn the knob clockwise one click at a time the standby value of 318.00 changes as follows:
32.8, 4.3, 1.4, 1.1

If I turn the knob anti-clockwise one click at a time the standby value of 318.00 changes as follows:
30.8, 2.1, 6552.8

This is why I started trying sim-connect.

Am I missing something?

Kind regards

Sean

Post Reply