X.52 Pro settings

Discussions about new feature ideas.
To request a new feature please open a ticket
Locked
etk
Passenger
Posts: 3
Joined: 10 Oct 2017, 13:55
Status: Offline

X.52 Pro settings

Post by etk » 10 Oct 2017, 14:35

A few issues that I came accross setting up my X.52 Pro for the P3D Sim.

First of all: I have disabled the controllers is P3D via Options/Controls/Other/EnableController UN-checked. Right? Otherwise P3D and SPAD.Next are interfering with each other.

Hat switch
What I am looking for is a setting for the hat switch to be able to pan left or right in my P3D sim.

The Hat switch "East pressed" event is populated with the "Send Pan Right Event" and for the other switches: West=Pan Left, North=Pan Up, South=Pan Down.

If I set the buttontypes to "Repeat, triggered every 25ms until released" the settings will always revert back to "Normal not modified". At the end this hat switch must be toggled multiple times to Pan all the way into one direction instead of being pressed and held until required. If I leave it up to P3D with Options/Controls/Other/EnableController checked the hat switch will pan until the button is released.
Any body got a solution for this?

Button_7, Button_8
Related to this is the fact that there appears no long-press event AND short-press event possible for the same button.
For instance for Button_8 and Button_7 I would like to be able to make a distinction betwee a long press and a short press as is possible for the Saitek Multi Panel and Radio Panel switches.
Should I configure these differently?

Button_31
Button_31 seems not to be responding at all. If I use the setting within P3D I can use this button.
Did I miss something?

I hope somebody can help me n the right direction. Thanks.

etk
Passenger
Posts: 3
Joined: 10 Oct 2017, 13:55
Status: Offline

Re: X.52 Pro settings

Post by etk » 12 Oct 2017, 11:08

To answer the Button_31 issue.
Go to Windows Control Panel / Devices and Printers. Right click on the X52 icon and select Settings. Now a window pops up where you are able to test all the buttons and axes on the X52. Click on the MFD tab and UN-check the Clutch Settings/Enable Clutch Mode checkbox.
I could not program the Function and the MFD select buttons though.

Locked