Page 1 of 1

Arduino UNO not Connecting to Spad

Posted: 20 Oct 2019, 06:54
by Steve Horsfall
Information for new persons experimenting with UNO and Spad.
Trying for weeks to get my UNO's to talk to Spad. When first connected I can select the COM port and set it up. When Screen is refreshed the COM Port dissapears and I cannot see it in the serial connection but is in the config file.
Serial Device.PNG
I tried this on the Sim PC with WIN7 and the Laptop with WIN10.Still the same result. I purchased another UNO thinking it was the device at fault, although it worked stand alone projects .
Lots of advice from cOnnex and Oz Flyer, as they had no problem, but mine are still not working.
With a bit of logic I worked out the PC's are OK, Spad works Ok and the UNO's are OK. Must be a problem with Arduino software although It verifed and uploaded with the Spad Demo program.
I finally removed CMDMessanger from the Arduino library and down loaded another version. Now both UNO's connect to Spad. :D