For PMDG 737 NGXu support the SPAD.neXt Beta 0.9.7 is needed.
An updated LVAR bridge setup with Prepar3d v5 support is available at ...

FIPS D: Drive

Discussion about Problems.
Forum rules
If you have technical Problem, please open a ticket:

Do NOT hijack other people threads, until you have exactly the same problem!
Posts: 2
Joined: 16 Oct 2019, 15:30
Location: Australia
Status: Offline

FIPS D: Drive

Post by vk2war » 17 Oct 2019, 02:24

Okay I am writing this for the second time as it appears I apparently didnt log back in again,. Weird.

Anyway, I wrote a Chapter of my first book about this already so I am going to keep this one quick.

Do I need to have all my Steam programs that will use my FIPS installed on C drive, or can I get this blasted Driver into where it needs to be so that SPAD.Next can stop asking me to install the Saitek drivers for it.

DXDiag sees both devices. in Device Manager I cannot see it. Neither the Switch unit, nor the FIPS show up. I just have generic USB devices and lots of them, and I have no idea which is which and it would probably take me a month to cross reference which device numerator and manufacturer numerator are which.

I want to say a couple of things. Firstly I am dunce for not knowing that existed. Maybe I should have done a little research first before believing that they would just be plug and play. I have the Radio and Multi Function units arriving today.

I did try and find a solution on here, however, as you say do not hijack anyone elses thread so thats why this one is here. Nothing seemed to work.

My Switch unit is working fine.

My FIPS shows a back light, goes through some flashing when it starts up, so I am guessing something works, but all I see is the back light. Not one instrument.

Okay, now to what I have and what I am using. Oh and thank you by the way for providing me with a Dark Mode. I have spent the last year since my last spinal fusion turning everything into some kind of dark mode as I received the added benefits of being both almost blind in my dominant right eye and extremely photosensitive to the point I practically live in the dark. Whether it be themes browser plugins I have it almost all working. You should have seen the day I figured out how to get a PDF file with a black background and white text. Was better than my Xmas.

Alright, here are my specs before you ask:

I am running Windows 10 Pro

My PC :

Thermaltake 850W Power Supply (Gold)
Asus ROG Zenith Extreme Apha Motherboard
AMD Threadripper 2950X
Thermaltake RGB CPU AIO Water Cooling system
64GB 3200 Corsair RGB Ram
Asus ROG Strix 11GB 2950X Graphics Card
C:\ is a Samsung 970 m.2 1TB drive
D:\ is a Samsung 970 m.2 500GB drive.
Multiple drives after that.
3 x AOC 32" 4k monitors

HP Reverb WMR VR Goggles.
Playing back video, faces are actually visible to me. I learned this by shoving on my Fatshark FPV goggles. I was into racing Micro Drones (Tiny Whoops) before my surgery. As my Dominant Right hand is severely nerve damaged, and Im full of titanium, lasting 3 minutes flying a micro was about all I could do at once. Far cry from what I did in the Military but it was something. But with a crappy 600tvl camera I realised that I could see faces and all the detail I cannot, just by shoving a drone on my head with my goggles on and hobbling around the house.

Anyway, back on point. When I first plugged in the Switch unit, I had no lights, show up, so I did the usual, install the drivers, which ceremoniously went straight into C drive (thanks for the choice logitech).

So I copied and pasted them into my FSX:SE drive (I have X-Plane 11 too just havent gotten around to that yet).

That didnt do me any favours, so I researched, found out about this forum and Read the forum looking for help, realised that you were not supposed to put drivers in. So I removed them 1 file at a time.

I then got an LVARS error when installing it, as it said it couldnt place the log file into some DLL directory on C drive.

I learned you could disengage that by deselecting it and It worked.

I got the switch to light up, and it seems relatively okay, but I need to learn a little more about actually programming the switches as a couple are back to front. Thats okay, at least I got the undercarriage lights to work, so at least that unit does in fact work.

My FIPS however, well, as I said, after being told Not to put in the drivers, I am getting a put in the drivers error.

So at this stage I cannot tell whether the unit works or it is faulty. First thing they teach you in Weapons Electrical Engineering Category School when it comes to all the really cool tech we get to play with and maintain is check the Power Rails first.

I am running two 3.0 hubs off of two of the 3.1/3.0 USB ports on my motherboard. I have unplugged everything and just run one, and I have also plugged into a spare USB 3.0 port directly to the PC and nothing shows me an instrument.

Hence we are back to the cant see the driver issue. Now I have no Idea where the drive for it went or what its labelled so that I could pull it out and place it somewhere. I am guessing its some kind of DLL file and not an INF file.

I could be wrong about that, if it was a file that the entire system could see I am guessing SPAD would see it too.

Hope that is enough to get this sorted out. It was my intention to get 6 of these gauges or more, and maybe a G1000 or similar type panel so that my 7 year old who cannot understand why she cannot use daddy's VR goggles because of the lenses I have to have in them to see, can have a go, because she keeps begging me to "Play". Which I want to encourage as I was flying planes before I could legally drive until my scholarship ran out.

It may have been a cheaper alternative to just grab a preinstalled cockpit. But that is out of my scope at this time.

So once again, thanx for the dark mode, I will re-assess which version I am going to get as it is quite obvious that Logitech has left everyone in the dark.


User avatar
Posts: 1731
Joined: 28 Mar 2015, 10:47
Location: United Kingdom
Status: Offline

Re: FIPS D: Drive

Post by thedazman » 17 Oct 2019, 08:18

As you said “I’ll keep it short”

FIPs need the inf driver and will NOT work on usb3.0

"theDAZman" aka "theGFXguy"

Posts: 2
Joined: 16 Oct 2019, 15:30
Location: Australia
Status: Offline

Re: FIPS D: Drive

Post by vk2war » 17 Oct 2019, 17:27

Worked a treat mate, thanks heaps !

User avatar
Steve Horsfall
Posts: 58
Joined: 21 Mar 2018, 02:11
Location: Macksville near YNHS,Australia
Status: Offline

Re: FIPS D: Drive

Post by Steve Horsfall » 17 Oct 2019, 22:08

Looks like you will be running a lot of panels and fips. You might have a power problem later.Have a look at the above post.73

User avatar
Oz Flyer
Posts: 723
Joined: 23 Sep 2015, 10:10
Location: YMMB, Melbourne, Australia
Status: Offline

Re: FIPS D: Drive

Post by Oz Flyer » 17 Oct 2019, 23:05

I see we have yet another VK

OZ Flyer
40+ year of Flight Siming.
Sim: subLOGIC/Microsoft Flight Sim's/DTG FSX, Microsoft Flight, DTG Filght School/FSW/Train Sim/TSW, ETS2 & ATS.
Hardware: Logitech, Saitek, Arduino 2560's & Leo's, BBI-32, PAC LED.