Current SPAD.neXt Release: 0.9.10.0

MSFS 2020 - MP and Radio Panel Displays won't turn on

Discussion about Problems.
Forum rules
If you have technical Problem, please open a ticket: https://www.spadnext.com/discover/how-to/get-help.html

Do NOT hijack other people threads, until you have exactly the same problem!
Post Reply
Yohannas
Passenger
Posts: 6
Joined: 16 Aug 2018, 16:05
Status: Offline

MSFS 2020 - MP and Radio Panel Displays won't turn on

Post by Yohannas » 22 Nov 2020, 14:38

Hi all, I'm using MSFS2020 with SPAD.next and everything is working - except the displays, which are blank. I've made sure 'virtual power' is on within the software, and I've also disabled Windows enhanced power management for both devices, but still nothing. They're both directly plugged into my motherboard's USB-A 3.0 ports.

The displays are calibrated correctly in the software to display values, and I can see the right values on the displays within the software. But they just won't show up on the hardware screens - the MP panel shows the redd-ish backlight, but no actual information, while the radio panel displays are dark.

It's hard to believe they would both be broken so I expect this is a software issue. Any help would be hugely appreciated!

Yohannas
Passenger
Posts: 6
Joined: 16 Aug 2018, 16:05
Status: Offline

Re: MSFS 2020 - MP and Radio Panel Displays won't turn on

Post by Yohannas » 24 Nov 2020, 11:23

SOLVED - The main USB controller still had 'Enhanced Power Management' enabled.

Post Reply