Current SPAD.neXt Release: 0.9.12.85

This forum has been set to readonly. Please join our Discord Community.

SPAD.neXt online services are no longer available for SPAD.neXt Versions < 0.9.11.5

SPAD.neXt crashes after a few seconds

Frequently asked Questions
Locked
User avatar
c0nnex
Site Admin
Posts: 5469
Joined: 10 Mar 2015, 21:52
Location: Munich, Germany
Contact:
Status: Offline

SPAD.neXt crashes after a few seconds

Post by c0nnex » 11 Aug 2015, 15:32

If SPAD.neXt crashes after a few seconds before even showing something, please check the logfile (logs/spad.log or logs/error.log).
If it contains something like
The type initializer for 'System.Windows.Automation.Peers.AutomationPeer' threw an exception. ---> System.TypeInitializationException: The type initializer for 'System.Windows.Automation.InvokePatternIdentifiers' threw an exception. ---> System.BadImageFormatException
This is due to the fact that the UIAutomation.dll that is being tried to load does match your System-Archtecture (64 vs. 32 bit).
Most likely you installed a custom UIAutomation.dll on your system to make FSX/P3D work on 64bit, and installed that dll in the system and did not just copy it to the FSX/P3D Directory.

Most likely because you installed a custom UIAutomation.dll.

First you should try the repair-function of the .Net Framework 4.5 in System Control Center -> Add/Remove Programs

If that does not help, try copying the UIAutomation.dll from your FSX/P3D Directory to the main Directory of SPAD.neXt.

You can also install the required UIAutomation.dll gathered from the Microsoft page: https://support.microsoft.com/en-us/kb/971513

Locked